about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/nvim/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/conf/nvim/default.nix')
-rw-r--r--modules/home.legacy/conf/nvim/default.nix55
1 files changed, 55 insertions, 0 deletions
diff --git a/modules/home.legacy/conf/nvim/default.nix b/modules/home.legacy/conf/nvim/default.nix
new file mode 100644
index 00000000..2da80c22
--- /dev/null
+++ b/modules/home.legacy/conf/nvim/default.nix
@@ -0,0 +1,55 @@
+{pkgs, ...}: {
+  imports = [
+    ./autocmds
+    ./clipboard
+    ./files
+    ./mappings
+    ./options
+    ./plgs
+  ];
+  home.sessionVariables = {
+    EDITOR = "nvim";
+    VISUAL = "nvim";
+    CODEEDITOR = "nvim";
+  };
+  programs.nixvim = {
+    enable = true;
+
+    # source: https://www.patorjk.com/software/taag/#p=display&f=ANSI%20Shadow&t=Neovim
+    extraConfigLuaPre =
+      /*
+       FIXME: Update the merge function to support that: <2023-08-29>
+
+      lib.mkBefore
+      */
+      ''
+        ---------------------------------------------------------------------------
+        --
+        --     ███╗   ██╗███████╗ ██████╗ ██╗   ██╗██╗███╗   ███╗
+        --     ████╗  ██║██╔════╝██╔═══██╗██║   ██║██║████╗ ████║
+        --     ██╔██╗ ██║█████╗  ██║   ██║██║   ██║██║██╔████╔██║
+        --     ██║╚██╗██║██╔══╝  ██║   ██║╚██╗ ██╔╝██║██║╚██╔╝██║
+        --     ██║ ╚████║███████╗╚██████╔╝ ╚████╔╝ ██║██║ ╚═╝ ██║
+        --     ╚═╝  ╚═══╝╚══════╝ ╚═════╝   ╚═══╝  ╚═╝╚═╝     ╚═╝
+        --
+        ---------------------------------------------------------------------------
+      '';
+
+    extraPackages = with pkgs; [
+      /*
+      These are mostly linters and formatters used for different file types.
+      Including them here is fine, as they are not necessarily sync able to different people.
+      */
+      # nix
+      alejandra
+      statix
+
+      # yaml
+      yamllint
+
+      # shell
+      shellcheck
+      shfmt
+    ];
+  };
+}