about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/git/aliases.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/conf/git/aliases.nix')
-rw-r--r--modules/home.legacy/conf/git/aliases.nix82
1 files changed, 0 insertions, 82 deletions
diff --git a/modules/home.legacy/conf/git/aliases.nix b/modules/home.legacy/conf/git/aliases.nix
deleted file mode 100644
index 15bf613d..00000000
--- a/modules/home.legacy/conf/git/aliases.nix
+++ /dev/null
@@ -1,82 +0,0 @@
-{
-  lib,
-  config,
-}: {
-  cmr = "commit --file .git/COMMIT_EDITMSG --edit --verbose";
-
-  st = "status";
-  sts = "status --short --branch";
-
-  ds = "diff --staged";
-  di = "diff";
-  rs = "restore --staged";
-
-  ## Logging:
-  ls = "log --max-count=10 --color --format=format:'%C(bold red)%h%C(reset) %C(dim bold blue)%s%C(reset) %C(dim white)[%aN] %C(bold red)<%G?>%C(reset)%C(auto)%d%C(reset)'";
-
-  # https://stackoverflow.com/a/61487052
-  lg = "lg1";
-  lg1 = "lg1-specific --all";
-  lg2 = "lg2-specific --all";
-  lg3 = "lg3-specific --all";
-
-  lg1-specific = "log --graph --abbrev-commit --decorate \
-                      --format=format:'%C(bold blue)%h%C(reset) - %C(bold green)(%ar)%C(reset) %C(white)%s%C(reset) %C(dim white)- %an%C(reset)%C(bold cyan) [%G?]%C(reset)%C(auto)%d%C(reset)'";
-
-  lg2-specific = "log --graph --abbrev-commit --decorate \
-                      --format=format:'%C(bold blue)%h%C(reset) - %C(bold cyan)%aD%C(reset) %C(bold green)(%ar)%C(reset)%C(auto)%d%C(reset)%n''          %C(white)%s%C(reset) %C(dim white)- %an%C(reset)'";
-
-  lg3-specific = "log --graph --abbrev-commit --decorate \
-                      --format=format:'%C(bold blue)%h%C(reset)\
-                      - %C(bold cyan)%aD%C(reset) %C(bold green)(%ar)%C(reset)\
-                      %C(bold cyan)(committed: %cD)%C(reset) %C(auto)%d%C(reset)\
-                      %C(bold red)(signature: %G? by %GS, trust: %GT)%C(reset)%n\
-                      ''          %C(white)%s%C(reset)%n''\
-                      %C(dim white)- %an <%ae> %C(reset) %C(dim white)(committer: %cn <%ce>)%C(reset)\
-                      %C(bold white)- trailers: %(trailers) %C(reset)'";
-
-  # hard reset with commit before (use reflog to recover)
-  #    git wipe [<commit>]
-  wipe = lib.strings.concatStringsSep " " [
-    "!git"
-    "add"
-    "--all"
-    "&&"
-    "git"
-    "commit"
-    "--quiet"
-    "--message='WIPE-SAVEPOINT'"
-    "--no-gpg-sign"
-    "&&"
-    "git reset \${1:-HEAD~} --hard"
-    "&&"
-    "git clean -fd"
-  ];
-
-  branches = lib.strings.concatStringsSep " " [
-    "!git"
-    "for-each-ref"
-    "--sort=-committerdate"
-    "--color=always"
-    "--format='${
-      lib.strings.concatStringsSep "|" [
-        "%(color:blue)%(authordate:relative)"
-        "%(color:red)%(authorname)"
-        "%(color:green)%(color:bold)%(refname:short)"
-      ]
-    }'"
-    "refs/remotes"
-    "|"
-    "column -ts'|' -o '   '"
-  ];
-
-  tags = "tag --list";
-
-  remotes = "remote --verbose";
-
-  day = "!git log --stat --since '1 day ago' --author $(git config user.email)";
-
-  unpush = "push --force-with-lease origin HEAD~1:${config.programs.git.extraConfig.init.defaultBranch}";
-
-  wip = "!git add . && git commit --amend && git push --force-with-lease";
-}