about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/firefox/scripts/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/conf/firefox/scripts/default.nix')
-rw-r--r--modules/home.legacy/conf/firefox/scripts/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/modules/home.legacy/conf/firefox/scripts/default.nix b/modules/home.legacy/conf/firefox/scripts/default.nix
new file mode 100644
index 00000000..1127662b
--- /dev/null
+++ b/modules/home.legacy/conf/firefox/scripts/default.nix
@@ -0,0 +1,29 @@
+{
+  pkgs,
+  sysLib,
+  ...
+}: let
+  unzip_mozlz4 = pkgs.stdenv.mkDerivation {
+    name = "unzip_mozlz4";
+    propagatedBuildInputs = [
+      (pkgs.python3.withPackages (pythonPackages:
+        with pythonPackages; [
+          lz4
+        ]))
+    ];
+    dontUnpack = true;
+    installPhase = "install -Dm755 ${./unzip_mozlz4.py} $out/bin/unzip_mozlz4";
+  };
+  extract_cookies = sysLib.writeShellScript {
+    name = "extract_cookies";
+    src = ./extract_cookies.sh;
+    dependencies = with pkgs; [
+      bash
+      sqlite
+      mktemp
+      coreutils
+    ];
+  };
+in {
+  inherit unzip_mozlz4 extract_cookies;
+}