about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/firefox/config/bookmarks/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/conf/firefox/config/bookmarks/default.nix')
-rw-r--r--modules/home.legacy/conf/firefox/config/bookmarks/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/modules/home.legacy/conf/firefox/config/bookmarks/default.nix b/modules/home.legacy/conf/firefox/config/bookmarks/default.nix
new file mode 100644
index 00000000..c612bf4d
--- /dev/null
+++ b/modules/home.legacy/conf/firefox/config/bookmarks/default.nix
@@ -0,0 +1,31 @@
+{
+  lib,
+  pkgs,
+  ...
+}: let
+  bookmarks = [
+    {
+      name = "Feed - Piped";
+      url = "https://piped.video/feed";
+    }
+
+    {
+      name = "DeepL Translate";
+      url = "https://www.deepl.com/translator";
+    }
+
+    {
+      name = "Nix lib";
+      url = "https://teu5us.github.io/nix-lib.html";
+    }
+
+    {
+      name = "Nixpkgs manual";
+      url = "https://ryantm.github.io/nixpkgs/";
+    }
+  ];
+
+  mkBookmarksFile = (import ./lib.nix) {inherit lib pkgs;};
+  bookmarks_file = mkBookmarksFile bookmarks;
+in
+  bookmarks_file