about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/beets/plugins/replaygain/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/conf/beets/plugins/replaygain/default.nix')
-rw-r--r--modules/home.legacy/conf/beets/plugins/replaygain/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/modules/home.legacy/conf/beets/plugins/replaygain/default.nix b/modules/home.legacy/conf/beets/plugins/replaygain/default.nix
new file mode 100644
index 00000000..611f3799
--- /dev/null
+++ b/modules/home.legacy/conf/beets/plugins/replaygain/default.nix
@@ -0,0 +1,24 @@
+{...}: {
+  programs.beets.settings = {
+    replaygain = {
+      auto = true;
+      backend = "ffmpeg";
+
+      r128_targetlevel = 89;
+
+      # Re-calculate the replay gain value even for files, that already have one set.
+      overwrite = true;
+    };
+
+    hook = {
+      hooks = [
+        {
+          # Also generate the replaygain for the album variant (so selecting between
+          # track and album becomes possible)
+          event = "import";
+          command = "echo Remember to run 'beet replaygain --album' to generate the album replaygain values for the imported songs!";
+        }
+      ];
+    };
+  };
+}