about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/beets/plugins/badfiles/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/conf/beets/plugins/badfiles/default.nix')
-rw-r--r--modules/home.legacy/conf/beets/plugins/badfiles/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/modules/home.legacy/conf/beets/plugins/badfiles/default.nix b/modules/home.legacy/conf/beets/plugins/badfiles/default.nix
new file mode 100644
index 00000000..33884785
--- /dev/null
+++ b/modules/home.legacy/conf/beets/plugins/badfiles/default.nix
@@ -0,0 +1,13 @@
+{
+  lib,
+  pkgs,
+  ...
+}: {
+  programs.beets.settings.badfiles = {
+    check_on_import = true;
+    commands = {
+      flac = "${lib.getExe' pkgs.flac "flac"} --test --warnings-as-errors --silent";
+      mp3 = "${lib.getExe pkgs.mp3val}";
+    };
+  };
+}