about summary refs log tree commit diff stats
path: root/modules/by-name/nv/nvim/plgs/todo-comments/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/by-name/nv/nvim/plgs/todo-comments/default.nix')
-rw-r--r--modules/by-name/nv/nvim/plgs/todo-comments/default.nix57
1 files changed, 57 insertions, 0 deletions
diff --git a/modules/by-name/nv/nvim/plgs/todo-comments/default.nix b/modules/by-name/nv/nvim/plgs/todo-comments/default.nix
new file mode 100644
index 00000000..ddbe367d
--- /dev/null
+++ b/modules/by-name/nv/nvim/plgs/todo-comments/default.nix
@@ -0,0 +1,57 @@
+{
+  config,
+  lib,
+  ...
+}: let
+  cfg = config.soispha.programs.nvim;
+in {
+  home-manager.users.soispha.programs.nixvim.plugins.todo-comments = lib.mkIf cfg.enable {
+    enable = true;
+    settings = {
+      guiStyle = {
+        fg = "BOLD";
+        bg = "NONE";
+      };
+      highlight = {
+        keyword = "wide_fg";
+      };
+      keywords = {
+        /*
+        # Defaults:
+        FIX = {
+          icon = " "; # Icon used for the sign, and in search results.
+          color = "error"; # Can be a hex color, or a named color.
+          alt = ["FIXME" "BUG" "FIXIT" "ISSUE"]; # A set of other keywords that all map to this FIX keywords.
+        };
+        TODO = {
+          icon = " ";
+          color = "info";
+        };
+        HACK = {
+          icon = " ";
+          color = "warning";
+        };
+        WARN = {
+          icon = " ";
+          color = "warning";
+          alt = ["WARNING" "XXX"];
+        };
+        PERF = {
+          icon = "󰅒 ";
+          alt = ["OPTIM" "PERFORMANCE" "OPTIMIZE"];
+        };
+        NOTE = {
+          icon = "󰍨 ";
+          color = "hint";
+          alt = ["INFO"];
+        };
+        TEST = {
+          icon = "⏲ ";
+          color = "test";
+          alt = ["TESTING" "PASSED" "FAILED"];
+        };
+        */
+      };
+    };
+  };
+}