about summary refs log tree commit diff stats
path: root/modules/by-name/nv/nvim/plgs/telescope/extensions/bibtex/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/by-name/nv/nvim/plgs/telescope/extensions/bibtex/default.nix')
-rw-r--r--modules/by-name/nv/nvim/plgs/telescope/extensions/bibtex/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/modules/by-name/nv/nvim/plgs/telescope/extensions/bibtex/default.nix b/modules/by-name/nv/nvim/plgs/telescope/extensions/bibtex/default.nix
new file mode 100644
index 00000000..e263cfdc
--- /dev/null
+++ b/modules/by-name/nv/nvim/plgs/telescope/extensions/bibtex/default.nix
@@ -0,0 +1,24 @@
+{
+  pkgs,
+  config,
+  lib,
+  ...
+}: let
+  cfg = config.soispha.programs.nvim;
+in {
+  # WARNING: This is only activated in tex files via the ftplugin.
+  home-manager.users.soispha.programs.nixvim = lib.mkIf cfg.enable {
+    extraPlugins = [
+      pkgs.vimExtraPlugins.telescope-bibtex-nvim
+    ];
+    keymaps = [
+      {
+        key = "<space>ib";
+        # This is registered in the ftplugin file, so we set this to null here
+        action = "<Nop>";
+        mode = "n";
+        options.desc = "[i]nsert a [b]atex citation";
+      }
+    ];
+  };
+}