about summary refs log tree commit diff stats
path: root/modules/by-name/nv/nvim/plgs/neorg/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/by-name/nv/nvim/plgs/neorg/default.nix')
-rw-r--r--modules/by-name/nv/nvim/plgs/neorg/default.nix94
1 files changed, 46 insertions, 48 deletions
diff --git a/modules/by-name/nv/nvim/plgs/neorg/default.nix b/modules/by-name/nv/nvim/plgs/neorg/default.nix
index 995f9601..67c18cc6 100644
--- a/modules/by-name/nv/nvim/plgs/neorg/default.nix
+++ b/modules/by-name/nv/nvim/plgs/neorg/default.nix
@@ -5,60 +5,58 @@
 }: let
   cfg = config.soispha.programs.nvim;
 in {
-  home-manager.users.soispha.programs.nixvim.plugins = lib.mkIf cfg.enable {
-    cmp.settings.sources = [
-      {name = "neorg";}
-    ];
+  home-manager.users.soispha.programs.nixvim = lib.mkIf cfg.enable {
+    extraFiles = {
+      "ftplugin/neorg.lua".text = ''
+        ${lib.strings.fileContents ./key_mappings.lua}
+      '';
+    };
 
-    neorg = {
-      enable = true;
-      lazyLoading = true;
+    plugins = {
+      cmp.settings.sources = [
+        {name = "neorg";}
+      ];
 
-      modules = {
-        "core.defaults" = {
-          __empty = null;
-        };
-        "core.esupports.metagen".config = {
-          type = "auto";
-        };
-        "core.journal".config = {
-          workspace = "journal";
-        };
-        "core.keybinds".config = {
-          hook = {
-            __raw = ''
-              function(keybinds)
-                  -- remap the looking glas to the same key, femaco is also mapped to.
-                  keybinds.remap_event("norg", "n", "<space>cc", "core.looking-glass.magnify-code-block")
+      neorg = {
+        enable = true;
+        lazyLoading = true;
 
-                  keybinds.remap_event("norg", "n", "<C-s>", "core.integrations.telescope.find_linkable")
-                  keybinds.remap_event("norg", "i", "<C-i>", "core.integrations.telescope.insert_link")
-              end,
-            '';
+        modules = {
+          "core.defaults" = {
+            __empty = null;
           };
-        };
-        "core.completion".config = {
-          engine = "nvim-cmp";
-        };
-        "core.concealer".config = {
-          __empty = null;
-        };
-        "core.dirman".config = {
-          workspaces = {
-            general = "~/repos/notes/general";
-            journal = "~/repos/notes/journal";
-            projects = "~/repos/notes/projects";
+          "core.esupports.metagen".config = {
+            type = "auto";
+          };
+          "core.journal".config = {
+            workspace = "journal";
+          };
+          "core.keybinds".config = {
+            __empty = null;
+          };
+          "core.completion".config = {
+            engine = "nvim-cmp";
+          };
+          "core.concealer".config = {
+            __empty = null;
+          };
+          "core.dirman".config = {
+            workspaces = {
+              general = "~/repos/notes/general";
+              journal = "~/repos/notes/journal";
+              projects = "~/repos/notes/projects";
+            };
+          };
+          "core.export".config = {
+            __empty = null;
+          };
+          "core.integrations.telescope".config = {
+            __empty = null;
           };
-        };
-        "core.export".config = {
-          __empty = null;
-        };
-        "core.integrations.telescope".config = {
-          __empty = null;
-        };
 
-        "core.ui.calendar".config = {
-          __empty = null;
+          "core.ui.calendar".config = {
+            __empty = null;
+          };
         };
       };
     };