about summary refs log tree commit diff stats
path: root/modules/by-name/nv/nvim/plgs/neorg/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/by-name/nv/nvim/plgs/neorg/default.nix')
-rw-r--r--modules/by-name/nv/nvim/plgs/neorg/default.nix70
1 files changed, 70 insertions, 0 deletions
diff --git a/modules/by-name/nv/nvim/plgs/neorg/default.nix b/modules/by-name/nv/nvim/plgs/neorg/default.nix
new file mode 100644
index 00000000..cf046e06
--- /dev/null
+++ b/modules/by-name/nv/nvim/plgs/neorg/default.nix
@@ -0,0 +1,70 @@
+{
+  config,
+  lib,
+  pkgsStable,
+  ...
+}: let
+  cfg = config.soispha.programs.nvim;
+in {
+  home-manager.users.soispha.programs.nixvim.plugins = lib.mkIf cfg.enable {
+    cmp.settings.sources = [
+      {name = "neorg";}
+    ];
+
+    neorg = {
+      package = pkgsStable.vimPlugins.neorg;
+      enable = true;
+      lazyLoading = true;
+
+      modules = {
+        "core.defaults" = {
+          __empty = null;
+        };
+        "core.esupports.metagen".config = {
+          type = "auto";
+        };
+        "core.journal".config = {
+          workspace = "journal";
+        };
+        "core.keybinds".config = {
+          hook = {
+            __raw = ''
+              function(keybinds)
+                  -- remap the looking glas to the same key, femaco is also mapped to.
+                  keybinds.remap_event("norg", "n", "<space>cc", "core.looking-glass.magnify-code-block")
+
+                  keybinds.remap_event("norg", "n", "<C-s>", "core.integrations.telescope.find_linkable")
+                  keybinds.remap_event("norg", "i", "<C-i>", "core.integrations.telescope.insert_link")
+              end,
+            '';
+          };
+        };
+        "core.completion".config = {
+          engine = "nvim-cmp";
+        };
+        "core.concealer".config = {
+          __empty = null;
+        };
+        "core.dirman".config = {
+          workspaces = {
+            general = "~/repos/notes/general";
+            journal = "~/repos/notes/journal";
+            projects = "~/repos/notes/projects";
+          };
+        };
+        "core.export".config = {
+          __empty = null;
+        };
+        "core.integrations.telescope".config = {
+          __empty = null;
+        };
+
+        # TODO: Add this when the nvim version in nixpkgs is >= 0.10 <2023-08-29>
+        #
+        # "core.ui.calendar".config = {
+        #   __empty = null;
+        # };
+      };
+    };
+  };
+}