about summary refs log tree commit diff stats
path: root/modules/by-name/nv/nvim/plgs/lsp/keymaps/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/by-name/nv/nvim/plgs/lsp/keymaps/default.nix')
-rw-r--r--modules/by-name/nv/nvim/plgs/lsp/keymaps/default.nix76
1 files changed, 76 insertions, 0 deletions
diff --git a/modules/by-name/nv/nvim/plgs/lsp/keymaps/default.nix b/modules/by-name/nv/nvim/plgs/lsp/keymaps/default.nix
new file mode 100644
index 00000000..903e8c17
--- /dev/null
+++ b/modules/by-name/nv/nvim/plgs/lsp/keymaps/default.nix
@@ -0,0 +1,76 @@
+{
+  config,
+  lib,
+  ...
+}: let
+  cfg = config.soispha.programs.nvim;
+in {
+  home-manager.users.soispha.programs.nixvim = lib.mkIf cfg.enable {
+    plugins.lsp.keymaps = {
+      diagnostic = {
+        "N" = {
+          action = "goto_prev";
+          desc = "go to previous diagnostic message";
+        };
+        "T" = {
+          action = "goto_next";
+          desc = "go to next diagnostic message";
+        };
+        "<space>e" = {
+          action = "open_float";
+          desc = "open float for the symbol";
+        };
+        "<space>gq" = {
+          action = "setloclist";
+          desc = "add buffer diagnostic to the location list (quick-fix)";
+        };
+      };
+      lspBuf = {
+        "<space>gD" = {
+          action = "declaration";
+          desc = "[G]o to [d]eclaration";
+        };
+        "<space>hi" = {
+          action = "hover";
+          desc = "Display [h]over [i]nformation";
+        };
+        "<space>sh" = {
+          action = "signature_help";
+          desc = "Display [s]ignature [h]elp";
+        };
+        "<space>wa" = {
+          action = "add_workspace_folder";
+          desc = "[W]orkspace folder [a]dd";
+        };
+        "<space>wr" = {
+          action = "remove_workspace_folder";
+          desc = "[W]orkspace folder [r]emove";
+        };
+        "<space>rn" = {
+          action = "rename";
+          desc = "[R]e[n]ame the item under the cursor";
+        };
+        "<space>ca" = {
+          action = "code_action";
+          desc = "Open the [c]ode [a]ction menu";
+        };
+      };
+    };
+    keymaps = [
+      {
+        key = "<space>f";
+        action.__raw = "function() vim.lsp.buf.format { async = true } end";
+        options.desc = "[F]ormat the current buffer (asynchronously)";
+      }
+      {
+        key = "<space>wl";
+        action.__raw = ''
+          function()
+            print(vim.inspect(vim.lsp.buf.list_workspace_folders()))
+          end
+        '';
+        options.desc = "[W]orkspace folders [l]ist";
+      }
+    ];
+  };
+}