about summary refs log tree commit diff stats
path: root/modules/by-name/nv/nvim/plgs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/by-name/nv/nvim/plgs/default.nix')
-rw-r--r--modules/by-name/nv/nvim/plgs/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/modules/by-name/nv/nvim/plgs/default.nix b/modules/by-name/nv/nvim/plgs/default.nix
new file mode 100644
index 00000000..991bc315
--- /dev/null
+++ b/modules/by-name/nv/nvim/plgs/default.nix
@@ -0,0 +1,33 @@
+{...}: {
+  imports =
+    [
+      # Plugins not yet packaged in nixpkgs
+      # ./debugprint
+      ./lf-nvim
+      # ./lsp-progress-nvim
+    ]
+    ++ [
+      # Already packaged in nixpkgs
+      ./colorscheme
+      ./comment-nvim
+      ./femaco
+      ./flatten-nvim
+      ./goto-preview
+      ./harpoon
+      ./leap
+      ./lsp
+      ./lspkind
+      ./ltex_extra
+      ./lualine
+      ./luasnip
+      ./neorg
+      ./nvim-cmp
+      ./nvim-lint
+      ./raw_plugins
+      ./telescope
+      ./todo-comments
+      ./treesitter
+      ./vim-tex
+      ./which-key
+    ];
+}