about summary refs log tree commit diff stats
path: root/modules/by-name/nv/nvim/plgs/debugprint/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/by-name/nv/nvim/plgs/debugprint/default.nix')
-rw-r--r--modules/by-name/nv/nvim/plgs/debugprint/default.nix73
1 files changed, 73 insertions, 0 deletions
diff --git a/modules/by-name/nv/nvim/plgs/debugprint/default.nix b/modules/by-name/nv/nvim/plgs/debugprint/default.nix
new file mode 100644
index 00000000..4a3af1c5
--- /dev/null
+++ b/modules/by-name/nv/nvim/plgs/debugprint/default.nix
@@ -0,0 +1,73 @@
+{
+  pkgs,
+  lib,
+  config,
+  ...
+}: let
+  cfg = config.soispha.programs.nvim;
+in {
+  home-manager.users.soispha.programs.nixvim = lib.mkIf cfg.enable {
+    # TODO: package debugprint though a module
+    extraConfigLuaPost = ''
+      ${lib.strings.fileContents ./lua/debugprint.lua}
+    '';
+    extraPlugins = [
+      pkgs.vimExtraPlugins.debugprint-nvim
+    ];
+
+    keymaps = [
+      {
+        key = "g?v";
+        mode = ["v" "n"];
+        action.__raw = ''
+          function()
+            return require('debugprint').debugprint({variable = true;});
+          end
+        '';
+        options.expr = true;
+        options.desc = ''
+          'variable' debug line below the current line
+        '';
+      }
+      {
+        key = "g?V";
+        mode = ["v" "n"];
+        action.__raw = ''
+          function()
+            return require('debugprint').debugprint({above = true; variable = true;}) ;
+          end
+        '';
+        options.expr = true;
+        options.desc = ''
+          'variable' debug line above the current line
+        '';
+      }
+      {
+        key = "g?p";
+        mode = "n";
+        action.__raw = ''
+          function()
+            return require('debugprint').debugprint();
+          end
+        '';
+        options.expr = true;
+        options.desc = ''
+          'plain' debug line below the current line
+        '';
+      }
+      {
+        key = "g?P";
+        mode = "n";
+        action.__raw = ''
+          function()
+            return require('debugprint').debugprint({above = true;});
+          end
+        '';
+        options.expr = true;
+        options.desc = ''
+          'plain' debug line above the current line
+        '';
+      }
+    ];
+  };
+}