about summary refs log tree commit diff stats
path: root/modules/by-name/im/imv/module.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/by-name/im/imv/module.nix')
-rw-r--r--modules/by-name/im/imv/module.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/modules/by-name/im/imv/module.nix b/modules/by-name/im/imv/module.nix
new file mode 100644
index 00000000..0a324e01
--- /dev/null
+++ b/modules/by-name/im/imv/module.nix
@@ -0,0 +1,21 @@
+{
+  config,
+  lib,
+  ...
+}: let
+  cfg = config.soispha.programs.imv;
+in {
+  options.soispha.programs.imv = {
+    enable = lib.mkEnableOption "imv";
+  };
+
+  config.home-manager.users.soispha = lib.mkIf cfg.enable {
+    programs.imv = {
+      enable = true;
+    };
+
+    home.sessionVariables = {
+      IVIEWER = "imv";
+    };
+  };
+}