about summary refs log tree commit diff stats
path: root/modules/by-name/bl/bluetooth/module.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/by-name/bl/bluetooth/module.nix')
-rw-r--r--modules/by-name/bl/bluetooth/module.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/modules/by-name/bl/bluetooth/module.nix b/modules/by-name/bl/bluetooth/module.nix
new file mode 100644
index 00000000..bf1c6a90
--- /dev/null
+++ b/modules/by-name/bl/bluetooth/module.nix
@@ -0,0 +1,20 @@
+{
+  config,
+  lib,
+  ...
+}: let
+  cfg = config.soispha.bluetooth;
+in {
+  options.soispha.bluetooth = {
+    enable = lib.mkEnableOption "an integrated bluetooth setup.";
+  };
+
+  config = lib.mkIf cfg.enable {
+    hardware = {
+      bluetooth = {
+        enable = true;
+        powerOnBoot = !config.soispha.laptop.enable;
+      };
+    };
+  };
+}