about summary refs log tree commit diff stats
path: root/hosts/tiamat/hardware/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/tiamat/hardware/default.nix')
-rw-r--r--hosts/tiamat/hardware/default.nix14
1 files changed, 3 insertions, 11 deletions
diff --git a/hosts/tiamat/hardware/default.nix b/hosts/tiamat/hardware/default.nix
index bb4596ec..be81253d 100644
--- a/hosts/tiamat/hardware/default.nix
+++ b/hosts/tiamat/hardware/default.nix
@@ -1,10 +1,4 @@
-{
-  config,
-  lib,
-  pkgs,
-  modulesPath,
-  ...
-}: {
+{modulesPath, ...}: {
   imports = [
     (modulesPath + "/installer/scan/not-detected.nix") # TODO is this necessary?
     ./cpu.nix
@@ -13,10 +7,8 @@
 
   nixpkgs.hostPlatform = "x86_64-linux";
 
-  system.fileSystemLayouts = {
-    enable = true;
-    mainDisk = "/dev/disk/by-uuid/4211a4ff-f2e9-41ed-83ca-712830fd0254";
-    efiDisk = "/dev/disk/by-uuid/2BFA-8F0F";
+  soispha.disks = {
+    disk = "/dev/disk/by-uuid/4211a4ff-f2e9-41ed-83ca-712830fd0254"; # TODO
     ssd = true;
     swap = {
       uuid = "4211a4ff-f2e9-41ed-83ca-712830fd0254";