about summary refs log tree commit diff stats
path: root/hosts/tiamat/hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/tiamat/hardware.nix')
-rw-r--r--hosts/tiamat/hardware.nix28
1 files changed, 3 insertions, 25 deletions
diff --git a/hosts/tiamat/hardware.nix b/hosts/tiamat/hardware.nix
index d8e62af0..8ecb4ce0 100644
--- a/hosts/tiamat/hardware.nix
+++ b/hosts/tiamat/hardware.nix
@@ -1,33 +1,9 @@
-{
-  modulesPath,
-  pkgs,
-  ...
-}: {
+{modulesPath, ...}: {
   imports = [
     (modulesPath + "/installer/scan/not-detected.nix") # TODO: is this necessary?
   ];
 
   hardware = {
-    #   opengl.extraPackages = with pkgs; [
-    #     rocm-opencl-icd # open-cl
-    #     amdvlk # or directly through mesa
-    #     amd-media-driver # libva
-    #   ];
-    #
-    #   # Force radv, TODO: is this logical?
-    #   environment.variables.AMD_VULKAN_ICD = "RADV";
-
-    opengl = {
-      enable = true;
-      extraPackages = with pkgs; [
-        vaapiVdpau
-        libvdpau-va-gl
-
-        amdvlk # or directly through mesa
-      ];
-    };
-
-    cpu.amd.updateMicrocode = true; # Why not?
     bluetooth = {
       enable = true;
       powerOnBoot = true;
@@ -37,10 +13,12 @@
   soispha = {
     hardware = {
       enable = true;
+      cpuType = "amd";
       moonlander = {
         enableFlashing = true;
       };
     };
+
     disks = {
       enable = true;
       disk = "/dev/disk/by-id/nvme-CT1000P5SSD8_21032C857568";