about summary refs log tree commit diff stats
path: root/hosts/marduk/hardware/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/marduk/hardware/default.nix')
-rw-r--r--hosts/marduk/hardware/default.nix19
1 files changed, 5 insertions, 14 deletions
diff --git a/hosts/marduk/hardware/default.nix b/hosts/marduk/hardware/default.nix
index f6500ed5..3a7b0a0a 100644
--- a/hosts/marduk/hardware/default.nix
+++ b/hosts/marduk/hardware/default.nix
@@ -1,28 +1,19 @@
+# vim: ts=2
 {
-  config,
   lib,
   pkgs,
   modulesPath,
   ...
 }: {
   imports = [
-    (modulesPath + "/installer/scan/not-detected.nix")
-    (modulesPath + "/installer/scan/detected.nix")
-    # (modulesPath + "/installer/cd-dvd/installation-cd-base.nix")
-
-    (modulesPath + "/profiles/base.nix")
-    (modulesPath + "/profiles/minimal.nix")
-    (modulesPath + "/profiles/all-hardware.nix")
+    (modulesPath + "/installer/cd-dvd/installation-cd-graphical-gnome.nix")
   ];
 
   nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
 
-  system.fileSystemLayouts = {
-    enable = true;
-    mainDisk = "/dev/disk/by-uuid/<uuid>";
-    efiDisk = "/dev/disk/by-uuid/<uuid>";
-  };
-
   boot = {
+    kernelModules = ["rtw89"];
+    kernelPackages = pkgs.linuxPackages_latest;
+    zfs.enableUnstable = true; # Default zfs is "broken" (to nixos) on the newest kernel
   };
 }