about summary refs log tree commit diff stats
path: root/hosts/isimud/hardware/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/isimud/hardware/default.nix')
-rw-r--r--hosts/isimud/hardware/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/hosts/isimud/hardware/default.nix b/hosts/isimud/hardware/default.nix
new file mode 100644
index 00000000..da4ded8d
--- /dev/null
+++ b/hosts/isimud/hardware/default.nix
@@ -0,0 +1,21 @@
+{
+  lib,
+  pkgs,
+  modulesPath,
+  ...
+}: {
+  imports = [
+    (modulesPath + "/installer/scan/not-detected.nix")
+  ];
+
+  hardware.cpu.amd.updateMicrocode = true; # Why not?
+  hardware.cpu.intel.updateMicrocode = true; # Why not?
+
+  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+
+  boot = {
+    kernelModules = [];
+    kernelPackages = pkgs.linuxPackages_6_1; # use this kernel, as it's supported by zfs
+    zfs.enableUnstable = true; # Default zfs is "broken" (to nixos) on the newest kernel
+  };
+}