about summary refs log tree commit diff stats
path: root/hosts/apzu/hardware/gpu.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/apzu/hardware/gpu.nix')
-rw-r--r--hosts/apzu/hardware/gpu.nix24
1 files changed, 17 insertions, 7 deletions
diff --git a/hosts/apzu/hardware/gpu.nix b/hosts/apzu/hardware/gpu.nix
index c3df51ae..180695e8 100644
--- a/hosts/apzu/hardware/gpu.nix
+++ b/hosts/apzu/hardware/gpu.nix
@@ -4,12 +4,22 @@
   lib,
   ...
 }: {
-  hardware.opengl.extraPackages = with pkgs; [
-    rocm-opencl-icd # open-cl
-    amdvlk # or directly through mesa
-    amd-media-driver # libva
-  ];
+  #   hardware.opengl.extraPackages = with pkgs; [
+  #     rocm-opencl-icd # open-cl
+  #     amdvlk # or directly through mesa
+  #     amd-media-driver # libva
+  #   ];
+  #
+  #   # Force radv, TODO is this logical?
+  #   environment.variables.AMD_VULKAN_ICD = "RADV";
 
-  # Force radv, TODO is this logical?
-  environment.variables.AMD_VULKAN_ICD = "RADV";
+  hardware.opengl = {
+    enable = true;
+    extraPackages = with pkgs; [
+      vaapiVdpau
+      libvdpau-va-gl
+
+      #amdvlk # or directly through mesa
+    ];
+  };
 }