about summary refs log tree commit diff stats
path: root/hosts/apzu/hardware/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/apzu/hardware/default.nix')
-rw-r--r--hosts/apzu/hardware/default.nix12
1 files changed, 3 insertions, 9 deletions
diff --git a/hosts/apzu/hardware/default.nix b/hosts/apzu/hardware/default.nix
index c989ee44..ab25c244 100644
--- a/hosts/apzu/hardware/default.nix
+++ b/hosts/apzu/hardware/default.nix
@@ -1,10 +1,4 @@
-{
-  config,
-  lib,
-  pkgs,
-  modulesPath,
-  ...
-}: {
+{modulesPath, ...}: {
   imports = [
     (modulesPath + "/installer/scan/not-detected.nix") # TODO is this necessary?
     ./cpu.nix
@@ -25,8 +19,8 @@
   };
 
   boot = {
-    kernelModules = ["kvm-amd" "rtw89"];
+    kernelModules = ["kvm-intel" "rtw89"];
 
-    initrd.availableKernelModules = ["nvme" "xhci_pci" "ahci" "usb_storage" "usbhid" "sd_mod"];
+    initrd.availableKernelModules = ["xhci_pci" "vmd" "nvme" "usb_storage" "sd_mod" "rtsx_pci_sdmmc"];
   };
 }