about summary refs log tree commit diff stats
path: root/hosts/apzu/hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/apzu/hardware.nix')
-rw-r--r--hosts/apzu/hardware.nix53
1 files changed, 15 insertions, 38 deletions
diff --git a/hosts/apzu/hardware.nix b/hosts/apzu/hardware.nix
index 29223e29..ae204baa 100644
--- a/hosts/apzu/hardware.nix
+++ b/hosts/apzu/hardware.nix
@@ -1,19 +1,22 @@
-{
-  modulesPath,
-  pkgs,
-  ...
-}: {
+{modulesPath, ...}: {
   imports = [
     (modulesPath + "/installer/scan/not-detected.nix") # TODO: is this necessary?
   ];
 
-  soispha.disks = {
-    enable = true;
-    disk = "/dev/disk/by-id/nvme-INTEL_SSDPEKNU512GZH_PHKA1481032A512A_1";
-    ssd = true;
-    swap = {
-      uuid = "c94cd20a-dd3c-436f-9841-6fe92e5c8719";
-      resumeOffset = "533760";
+  soispha = {
+    disks = {
+      enable = true;
+      disk = "/dev/disk/by-id/nvme-INTEL_SSDPEKNU512GZH_PHKA1481032A512A_1";
+      ssd = true;
+      swap = {
+        uuid = "c94cd20a-dd3c-436f-9841-6fe92e5c8719";
+        resumeOffset = "533760";
+      };
+    };
+
+    hardware = {
+      enable = true;
+      cpuType = "intel";
     };
   };
 
@@ -22,30 +25,4 @@
 
     initrd.availableKernelModules = ["xhci_pci" "vmd" "nvme" "usb_storage" "sd_mod" "rtsx_pci_sdmmc"];
   };
-
-  hardware = {
-    bluetooth = {
-      enable = true;
-      # Avoid some battery drain, requires a `power on` in bluetoothctl
-      powerOnBoot = false;
-    };
-
-    #   opengl.extraPackages = with pkgs; [
-    #     rocm-opencl-icd # open-cl
-    #     amdvlk # or directly through mesa
-    #     amd-media-driver # libva
-    #   ];
-    #
-    #   # Force radv, TODO: is this logical?
-    #   environment.variables.AMD_VULKAN_ICD = "RADV";
-
-    cpu.intel.updateMicrocode = true; # Why not?
-    opengl = {
-      enable = true;
-      extraPackages = with pkgs; [
-        vaapiVdpau
-        libvdpau-va-gl
-      ];
-    };
-  };
 }