about summary refs log tree commit diff stats
path: root/hosts/apzu/hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/apzu/hardware.nix')
-rw-r--r--hosts/apzu/hardware.nix51
1 files changed, 51 insertions, 0 deletions
diff --git a/hosts/apzu/hardware.nix b/hosts/apzu/hardware.nix
new file mode 100644
index 00000000..29223e29
--- /dev/null
+++ b/hosts/apzu/hardware.nix
@@ -0,0 +1,51 @@
+{
+  modulesPath,
+  pkgs,
+  ...
+}: {
+  imports = [
+    (modulesPath + "/installer/scan/not-detected.nix") # TODO: is this necessary?
+  ];
+
+  soispha.disks = {
+    enable = true;
+    disk = "/dev/disk/by-id/nvme-INTEL_SSDPEKNU512GZH_PHKA1481032A512A_1";
+    ssd = true;
+    swap = {
+      uuid = "c94cd20a-dd3c-436f-9841-6fe92e5c8719";
+      resumeOffset = "533760";
+    };
+  };
+
+  boot = {
+    kernelModules = ["kvm-intel" "rtw89"];
+
+    initrd.availableKernelModules = ["xhci_pci" "vmd" "nvme" "usb_storage" "sd_mod" "rtsx_pci_sdmmc"];
+  };
+
+  hardware = {
+    bluetooth = {
+      enable = true;
+      # Avoid some battery drain, requires a `power on` in bluetoothctl
+      powerOnBoot = false;
+    };
+
+    #   opengl.extraPackages = with pkgs; [
+    #     rocm-opencl-icd # open-cl
+    #     amdvlk # or directly through mesa
+    #     amd-media-driver # libva
+    #   ];
+    #
+    #   # Force radv, TODO: is this logical?
+    #   environment.variables.AMD_VULKAN_ICD = "RADV";
+
+    cpu.intel.updateMicrocode = true; # Why not?
+    opengl = {
+      enable = true;
+      extraPackages = with pkgs; [
+        vaapiVdpau
+        libvdpau-va-gl
+      ];
+    };
+  };
+}