about summary refs log tree commit diff stats
path: root/hosts/_unmaintained/marduk/hardware/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/_unmaintained/marduk/hardware/default.nix')
-rw-r--r--hosts/_unmaintained/marduk/hardware/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/hosts/_unmaintained/marduk/hardware/default.nix b/hosts/_unmaintained/marduk/hardware/default.nix
new file mode 100644
index 00000000..4fed1d06
--- /dev/null
+++ b/hosts/_unmaintained/marduk/hardware/default.nix
@@ -0,0 +1,19 @@
+{
+  lib,
+  pkgs,
+  modulesPath,
+  ...
+}: {
+  imports = [
+    (modulesPath + "/installer/cd-dvd/installation-cd-graphical-gnome.nix")
+  ];
+
+  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+
+  boot = {
+    kernelModules = ["rtw89"];
+    # FIXME: The kernel version should probably be updated, considering that it's 6.1 <2024-03-23>
+    kernelPackages = pkgs.linuxPackages_6_1; # use this kernel, as it's supported by zfs
+    zfs.package = pkgs.zfs_unstable; # Default zfs is "broken" (to nixos) on the newest kernel
+  };
+}