about summary refs log tree commit diff stats
path: root/hosts/_unmaintained/mammun/hardware/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/_unmaintained/mammun/hardware/default.nix')
-rw-r--r--hosts/_unmaintained/mammun/hardware/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/hosts/_unmaintained/mammun/hardware/default.nix b/hosts/_unmaintained/mammun/hardware/default.nix
new file mode 100644
index 00000000..b1683d47
--- /dev/null
+++ b/hosts/_unmaintained/mammun/hardware/default.nix
@@ -0,0 +1,27 @@
+{
+  config,
+  lib,
+  pkgs,
+  modulesPath,
+  ...
+}: {
+  imports = [
+    (modulesPath + "/installer/scan/not-detected.nix")
+    ./cpu.nix
+    ./gpu.nix
+  ];
+
+  nixpkgs.hostPlatform = "x86_64-linux";
+
+  system.fileSystemLayouts = {
+    enable = true;
+    mainDisk = "/dev/disk/by-uuid/ac6c5efd-51a7-42e7-a8cd-668a350554b1";
+    efiDisk = "/dev/disk/by-uuid/7931-40E5";
+  };
+
+  boot = {
+    kernelModules = ["kvm-amd"];
+
+    initrd.availableKernelModules = ["xhci_pci" "ahci" "ehci_pci" "sd_mod" "sr_mod" "sdhci_pci"];
+  };
+}