about summary refs log tree commit diff stats
path: root/hosts/_unmaintained/lahmu/networking.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/_unmaintained/lahmu/networking.nix')
-rw-r--r--hosts/_unmaintained/lahmu/networking.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/hosts/_unmaintained/lahmu/networking.nix b/hosts/_unmaintained/lahmu/networking.nix
new file mode 100644
index 00000000..1ef69e7c
--- /dev/null
+++ b/hosts/_unmaintained/lahmu/networking.nix
@@ -0,0 +1,14 @@
+{
+  config,
+  lib,
+  ...
+}: {
+  # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
+  # (the default) this is the recommended approach. When using systemd-networkd it's
+  # still possible to use this option, but it's recommended to use it in conjunction
+  # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
+  networking.useDHCP = lib.mkDefault true;
+  # networking.interfaces.enp0s31f6.useDHCP = lib.mkDefault true;
+  # networking.interfaces.wlp3s0.useDHCP = lib.mkDefault true;
+  networking.hostName = "lahmu";
+}