about summary refs log tree commit diff stats
path: root/hosts/_unmaintained/lahmu/hardware/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/_unmaintained/lahmu/hardware/default.nix')
-rw-r--r--hosts/_unmaintained/lahmu/hardware/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/hosts/_unmaintained/lahmu/hardware/default.nix b/hosts/_unmaintained/lahmu/hardware/default.nix
new file mode 100644
index 00000000..bc7b1f96
--- /dev/null
+++ b/hosts/_unmaintained/lahmu/hardware/default.nix
@@ -0,0 +1,33 @@
+{
+  config,
+  lib,
+  pkgs,
+  modulesPath,
+  ...
+}: {
+  imports = [
+    (modulesPath + "/installer/scan/not-detected.nix") # TODO: is this necessary?
+    (modulesPath + "/profiles/qemu-guest.nix")
+    ./cpu.nix
+    ./gpu.nix
+  ];
+
+  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+
+  system.fileSystemLayouts = {
+    enable = true;
+    mainDisk = "/dev/disk/by-uuid/c0382dda-1f55-4209-967d-b8b22cb0f6e1";
+    efiDisk = "/dev/disk/by-uuid/167D-2F0B";
+    ssd = true;
+    swap = {
+      uuid = "c0382dda-1f55-4209-967d-b8b22cb0f6e1";
+      resumeOffset = "140544";
+    };
+  };
+
+  boot = {
+    kernelModules = [];
+
+    initrd.availableKernelModules = ["ahci" "xhci_pci" "virtio_pci" "sr_mod" "virtio_blk"];
+  };
+}