about summary refs log tree commit diff stats
path: root/hosts/Tiamat/hardware/hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/Tiamat/hardware/hardware.nix')
-rw-r--r--hosts/Tiamat/hardware/hardware.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/hosts/Tiamat/hardware/hardware.nix b/hosts/Tiamat/hardware/hardware.nix
new file mode 100644
index 00000000..c36b7062
--- /dev/null
+++ b/hosts/Tiamat/hardware/hardware.nix
@@ -0,0 +1,28 @@
+{
+  config,
+  lib,
+  pkgs,
+  modulesPath,
+  ...
+}: {
+  imports = [
+    (modulesPath + "/installer/scan/not-detected.nix") # TODO is this necessary?
+    ./cpu.nix
+    ./gpu.nix
+  ];
+
+  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+
+  system.filesystemLayouts = {
+    enable = true;
+    mainDisk = "/dev/disk/by-uuid/<uuid>";
+    efiDisk = "/dev/disk/by-uuid/<uuid>";
+  };
+
+  boot = {
+    kernelModules = ["kvm-amd"];
+
+    # TODO check this:
+    initrd.availableKernelModules = ["xhci_pci" "nvme" "rtsx_pci_sdmmc"];
+  };
+}