about summary refs log tree commit diff stats
path: root/hosts/Tiamat/hardware/gpu.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/Tiamat/hardware/gpu.nix')
-rw-r--r--hosts/Tiamat/hardware/gpu.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/hosts/Tiamat/hardware/gpu.nix b/hosts/Tiamat/hardware/gpu.nix
new file mode 100644
index 00000000..c3df51ae
--- /dev/null
+++ b/hosts/Tiamat/hardware/gpu.nix
@@ -0,0 +1,15 @@
+{
+  config,
+  pkgs,
+  lib,
+  ...
+}: {
+  hardware.opengl.extraPackages = with pkgs; [
+    rocm-opencl-icd # open-cl
+    amdvlk # or directly through mesa
+    amd-media-driver # libva
+  ];
+
+  # Force radv, TODO is this logical?
+  environment.variables.AMD_VULKAN_ICD = "RADV";
+}