about summary refs log tree commit diff stats
path: root/hosts/Tiamat/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/Tiamat/configuration.nix')
-rw-r--r--hosts/Tiamat/configuration.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/hosts/Tiamat/configuration.nix b/hosts/Tiamat/configuration.nix
new file mode 100644
index 00000000..e42cb05f
--- /dev/null
+++ b/hosts/Tiamat/configuration.nix
@@ -0,0 +1,19 @@
+# vim: ts=2
+{
+  config,
+  lib,
+  nixpkgs,
+  home-manager,
+  ...
+}: {
+  imports = [
+    ./hardware/hardware.nix
+    ./networking.nix
+
+    ../../system/system.nix
+
+    ../../services/services.nix
+  ];
+
+  system.stateVersion = "23.05";
+}