about summary refs log tree commit diff stats
path: root/home-manager/config/gpg/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/config/gpg/default.nix')
-rw-r--r--home-manager/config/gpg/default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/home-manager/config/gpg/default.nix b/home-manager/config/gpg/default.nix
new file mode 100644
index 00000000..de6f7caa
--- /dev/null
+++ b/home-manager/config/gpg/default.nix
@@ -0,0 +1,20 @@
+{
+  config,
+  pkgs,
+  ...
+}: {
+  programs.gpg = {
+    enable = true;
+    homedir = "${config.xdg.dataHome}/gnupg/onlykey";
+    #mutableKeys = false;
+    #mutableTrust = false;
+    settings = {
+      # Hardware-based GPG configuration
+      agent-program =  "/home/soispha/.local/share/gnupg/onlykey/run-agent.sh";
+      default-key = "Soispha <soispha@vhack.eu>";
+      # TODO add more
+    };
+  };
+}
+# vim: ts=2
+