about summary refs log tree commit diff stats
path: root/hm/soispha/conf/nvim/plugins/femaco/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/conf/nvim/plugins/femaco/default.nix')
-rw-r--r--hm/soispha/conf/nvim/plugins/femaco/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/hm/soispha/conf/nvim/plugins/femaco/default.nix b/hm/soispha/conf/nvim/plugins/femaco/default.nix
new file mode 100644
index 00000000..6d7ec16a
--- /dev/null
+++ b/hm/soispha/conf/nvim/plugins/femaco/default.nix
@@ -0,0 +1,24 @@
+{
+  pkgs,
+  lib,
+  ...
+}: {
+  programs.nixvim = {
+    # TODO: package femaco though a module
+    extraConfigLuaPost = ''
+      ${lib.strings.fileContents ./lua/femaco.lua}
+    '';
+    extraPlugins = [
+      pkgs.vimPlugins.nvim-FeMaco-lua
+    ];
+    maps = {
+      normal = {
+        "<leader>cc" = {
+          action = "require('femaco.edit').edit_code_block()";
+          lua = true;
+          desc = "edit a [c]ode blo[c]k with femaco";
+        };
+      };
+    };
+  };
+}