about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix25
1 files changed, 24 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 7514aeca..0ff5d4b4 100644
--- a/flake.nix
+++ b/flake.nix
@@ -12,6 +12,11 @@
       url = "github:nix-community/home-manager/master";
       inputs.nixpkgs.follows = "nixpkgs";
     };
+
+    user_js = {
+      url = "github:arkenfox/user.js";
+      flake = false;
+    };
   };
 
   outputs = {
@@ -19,12 +24,30 @@
     nixpkgs,
     home-manager,
     strip_js_comments,
+    user_js,
     ...
   } @ inputs: {
     nixosConfigurations.Tiamat = nixpkgs.lib.nixosSystem {
       system = "x86_64-linux";
       specialArgs = inputs;
-      modules = [./hosts/desktop/configuration.nix (import ./home-manager/home.nix {})];
+      modules = [
+        ./hosts/desktop/configuration.nix
+        home-manager.nixosModules.home-manager
+        {
+          home-manager = {
+            useGlobalPkgs = true;
+            useUserPackages = true;
+            users.soispha = import ./home-manager;
+            extraSpecialArgs = {
+              inherit strip_js_comments;
+              inherit user_js;
+            };
+          };
+
+          # Optionally, use home-manager.extraSpecialArgs to pass
+          # arguments to home.nix
+        }
+      ];
     };
     #    nixosConfigurations.Apzu = nixpkgs.lib.nixosSystem {
     #      system = "x86_64-linux";