about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index ab5751ed..aaf47b28 100644
--- a/flake.nix
+++ b/flake.nix
@@ -12,6 +12,9 @@
     };
 
     # inputs for following
+    systems = {
+      url = "github:nix-systems/x86_64-linux"; # only evaluate for this system
+    };
     flake-compat = {
       url = "github:edolstra/flake-compat";
       flake = false;
@@ -29,6 +32,7 @@
     flake-utils = {
       url = "github:numtide/flake-utils";
       inputs = {
+        systems.follows = "systems";
       };
     };
 
@@ -36,7 +40,7 @@
       url = "github:oxalica/rust-overlay";
       inputs = {
         nixpkgs.follows = "nixpkgs";
-        flake-utils.follows = "flake-utils";
+        systems.follows = "systems";
       };
     };