about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index d68a4c94..6c6a1c3c 100644
--- a/flake.nix
+++ b/flake.nix
@@ -86,6 +86,15 @@
         crane.follows = "crane";
       };
     };
+    lanzaboote = {
+      url = "github:nix-community/lanzaboote";
+
+      inputs = {
+        flake-compat.follows = "flake-compat";
+        flake-utils.follows = "flake-utils";
+        nixpkgs.follows = "nixpkgs";
+      };
+    };
 
     # my configs
     neovim_config = {
@@ -213,6 +222,7 @@
     ragenix,
     serverphone,
     disko,
+    lanzaboote,
     # external dependencies
     neovim_config,
     user_js,
@@ -253,6 +263,7 @@
         ragenix
         serverphone
         disko
+        lanzaboote
         # external dependencies
         
         neovim_config