about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix17
1 files changed, 11 insertions, 6 deletions
diff --git a/flake.nix b/flake.nix
index 648b164a..f56b5e21 100644
--- a/flake.nix
+++ b/flake.nix
@@ -3,9 +3,10 @@
 
   inputs = {
     # base
+    nixpkgs-stable.url = "github:NixOS/nixpkgs/nixos-23.05";
     nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
+    # open nixpkgs prs
     nixpkgs-tfc.url = "github:soispha/nixpkgs/add-termfilechooser";
-    nixpkgs-stable.url = "github:NixOS/nixpkgs/nixos-23.05";
 
     # inputs for following
     systems = {
@@ -272,7 +273,11 @@
 
     # FIXME: this `nixpkgs` misses the configs applied to the other one
     nixpkgs_as_input = nixpkgs;
-    nixpkgs_tfc = nixpkgs-tfc;
+    nixpkgs_open_prs = {
+      inherit
+        nixpkgs-tfc
+        ;
+    };
     outputs = import ./flake {
       inherit
         # core
@@ -281,9 +286,9 @@
         system
         sysLib
         nixpkgs_as_input
-        nixpkgs_tfc
+        nixpkgs_open_prs
         # modules
-        
+
         home-manager
         nixVim
         nixos-generators
@@ -295,12 +300,12 @@
         lanzaboote
         nix-index-database
         # external dependencies
-        
+
         treefmt-nix
         user_js
         templates
         # my binaries
-        
+
         shell_library
         river_init_lesser
         yambar_memory