about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix11
1 files changed, 7 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index f2fc62d2..d6130388 100644
--- a/flake.nix
+++ b/flake.nix
@@ -26,12 +26,14 @@
       url = "git+https://codeberg.org/ene/strip_js_comments.git";
       inputs.nixpkgs.follows = "nixpkgs";
     };
-
+    shell-library = {
+      url = "git+https://git.sils.li/ene/lib-sh.git";
+      flake = false;
+    };
     user_js = {
       url = "github:arkenfox/user.js";
       flake = false;
     };
-
     snap-sync = {
       url = "github:qubidt/snap-sync";
       flake = false;
@@ -48,6 +50,7 @@
     impermanence,
     agenix,
     snap-sync,
+    shell-library,
     ...
   } @ inputs: {
     nixosConfigurations.Tiamat = nixpkgs.lib.nixosSystem rec {
@@ -81,11 +84,11 @@
       modules = [./hosts/spawn/configuration.nix];
     };
 
-    packages."x86_64-linux".default = import ./bootstrap {pkgs = nixpkgs.legacyPackages.x86_64-linux;};
+    packages."x86_64-linux".default = import ./bootstrap {pkgs = nixpkgs.legacyPackages.x86_64-linux; inherit shell-library;};
 
     apps."x86_64-linux"."install" = {
       type = "app";
-      program = "${self.packages."x86_64-linux".default}";
+      program = "${self.packages."x86_64-linux".default}/bin/install";
     };
     apps."x86_64-linux".default = self.apps."x86_64-linux".install;
   };