about summary refs log tree commit diff stats
path: root/system/services/xdg/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-04-12 12:17:35 +0200
committerSoispha <soispha@vhack.eu>2023-05-09 19:30:28 +0200
commit35a423d3d1318a164c9e80548b7deb8b8350bed5 (patch)
treec9420c04bb943575e5bba44e6463e366172749f1 /system/services/xdg/default.nix
parentFix(hm/conf/swaylock): Pam permission issue (diff)
downloadnixos-config-35a423d3d1318a164c9e80548b7deb8b8350bed5.tar.gz
nixos-config-35a423d3d1318a164c9e80548b7deb8b8350bed5.zip
Fix(hm/wms/river): Activate wlr xdg portal
Diffstat (limited to 'system/services/xdg/default.nix')
-rw-r--r--system/services/xdg/default.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/system/services/xdg/default.nix b/system/services/xdg/default.nix
new file mode 100644
index 00000000..3b0233a2
--- /dev/null
+++ b/system/services/xdg/default.nix
@@ -0,0 +1,12 @@
+# vim: ts=2
+{pkgs, ...}: {
+  xdg = {
+    portal = {
+      enable = true;
+      # TODO only enable the below, when on river (or wlr based compositor)
+      wlr.enable = true;
+      extraPortals = [pkgs.xdg-desktop-portal-wlr];
+    };
+  };
+  # TODO mime = {};
+}