about summary refs log tree commit diff stats
path: root/system/services/openssh/default.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-03-17 17:42:23 +0100
committerene <ene@sils.li>2023-03-17 17:42:23 +0100
commit8978453ef0492c833d42599c758d25f8ed5afde0 (patch)
treee0652bf94479213be1a89945f9aa3d7eee1f9a45 /system/services/openssh/default.nix
parentFix(hm/conf/lf): Update to new shell lib version (diff)
downloadnixos-config-8978453ef0492c833d42599c758d25f8ed5afde0.tar.gz
nixos-config-8978453ef0492c833d42599c758d25f8ed5afde0.zip
Fix(system): Move services to system
Diffstat (limited to 'system/services/openssh/default.nix')
-rw-r--r--system/services/openssh/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/system/services/openssh/default.nix b/system/services/openssh/default.nix
new file mode 100644
index 00000000..5ee48a0c
--- /dev/null
+++ b/system/services/openssh/default.nix
@@ -0,0 +1,19 @@
+{
+  config,
+  pkg,
+  ...
+}: {
+  services.openssh = {
+    enable = true;
+    hostKeys = [
+      {
+        path = "/srv/sshd/ssh_host_ed25519_key";
+        rounds = 1000;
+        type = "ed25519";
+      }
+    ];
+    settings = {
+      PasswordAuthentication = false;
+    };
+  };
+}