about summary refs log tree commit diff stats
path: root/system/locale/locale.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-01 21:33:11 +0100
committerene <ene@sils.li>2023-02-03 17:34:11 +0100
commit871d3f95963eac25765427ecca9a8e4812071439 (patch)
tree5dcf241ece31050cf0c74219852242abe504e068 /system/locale/locale.nix
parentBuild(flake): Added Flake.lock (diff)
downloadnixos-config-871d3f95963eac25765427ecca9a8e4812071439.tar.gz
nixos-config-871d3f95963eac25765427ecca9a8e4812071439.zip
Feat: Split the config apart
Diffstat (limited to 'system/locale/locale.nix')
-rw-r--r--system/locale/locale.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/system/locale/locale.nix b/system/locale/locale.nix
new file mode 100644
index 00000000..2fcc2115
--- /dev/null
+++ b/system/locale/locale.nix
@@ -0,0 +1,26 @@
+{
+  config,
+  pkgs,
+  ...
+}: {
+  # Set your time zone.
+  time.timeZone = "Europe/Berlin";
+
+  # Select internationalisation properties.
+  i18n.defaultLocale = "en_US.UTF-8";
+
+  i18n.extraLocaleSettings = {
+    LC_ADDRESS = "de_DE.UTF-8";
+    LC_IDENTIFICATION = "de_DE.UTF-8";
+    LC_MEASUREMENT = "de_DE.UTF-8";
+    LC_MONETARY = "de_DE.UTF-8";
+    LC_NAME = "de_DE.UTF-8";
+    LC_NUMERIC = "de_DE.UTF-8";
+    LC_PAPER = "de_DE.UTF-8";
+    LC_TELEPHONE = "de_DE.UTF-8";
+    LC_TIME = "de_DE.UTF-8";
+  };
+
+  # Configure console keymap
+  console.keyMap = "dvorak";
+}