about summary refs log tree commit diff stats
path: root/sys/svcs/xdg/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-12-28 11:35:31 +0100
committerSoispha <soispha@vhack.eu>2023-12-28 11:35:31 +0100
commitb9d22e20a6c13c77944b04caacc0074fb7a6746c (patch)
tree8d3a8382ff3ff82cb36720fb1e881f568453fd81 /sys/svcs/xdg/default.nix
parentbuild(treewide): Update to test xdg-desktop-portal-termfilechooser (diff)
downloadnixos-config-b9d22e20a6c13c77944b04caacc0074fb7a6746c.tar.gz
nixos-config-b9d22e20a6c13c77944b04caacc0074fb7a6746c.zip
feat(sys/svcs/xdg/termchooser): Init
Diffstat (limited to 'sys/svcs/xdg/default.nix')
-rw-r--r--sys/svcs/xdg/default.nix19
1 files changed, 17 insertions, 2 deletions
diff --git a/sys/svcs/xdg/default.nix b/sys/svcs/xdg/default.nix
index 2de640dd..243c7c9d 100644
--- a/sys/svcs/xdg/default.nix
+++ b/sys/svcs/xdg/default.nix
@@ -1,8 +1,23 @@
-{pkgs, ...}: {
+{
+  pkgs,
+  sysLib,
+  ...
+}: {
   services.dbus.enable = true;
   xdg = {
     portal = {
       enable = true;
+      termfilechooser = {
+        enable = true;
+        settings = {
+          cmd = sysLib.writeShellScriptWithLibraryAndKeepPath {
+            name = "lf_wrapper";
+            src = ./scripts/lf_wrapper;
+            dependencies = with pkgs; [
+            ];
+          };
+        };
+      };
       config = {
         common = {
           # NOTE: The next entry is supposedly needed for gtk based apps <2023-08-31>
@@ -17,7 +32,7 @@
       extraPortals = with pkgs; [
         xdg-desktop-portal-gtk
         xdg-desktop-portal-wlr
-        # xdg-desktop-portal-termfilechooser
+        xdg-desktop-portal-termfilechooser
       ];
     };
   };