about summary refs log tree commit diff stats
path: root/pkgs/sources/yt/yts.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:26:22 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:26:22 +0200
commit204731c0a69136c9cebcb54f1afecf5145e26bbe (patch)
treefc9132e5dc74e4a8e1327cdd411839a90f9410aa /pkgs/sources/yt/yts.nix
parentrefactor(sys): Modularize and move to `modules/system` or `pkgs` (diff)
downloadnixos-config-204731c0a69136c9cebcb54f1afecf5145e26bbe.tar.gz
nixos-config-204731c0a69136c9cebcb54f1afecf5145e26bbe.zip
refactor(pkgs): Categorize into `by-name` shards
This might not be the perfect way to organize a package set --
especially if the set is not nearly the size of nixpkgs -- but it is
_at_ least a way of organization.
Diffstat (limited to 'pkgs/sources/yt/yts.nix')
-rw-r--r--pkgs/sources/yt/yts.nix27
1 files changed, 0 insertions, 27 deletions
diff --git a/pkgs/sources/yt/yts.nix b/pkgs/sources/yt/yts.nix
deleted file mode 100644
index 9a8b172e..00000000
--- a/pkgs/sources/yt/yts.nix
+++ /dev/null
@@ -1,27 +0,0 @@
-{
-  lib,
-  rustPlatform,
-  ytcc,
-  makeWrapper,
-}:
-rustPlatform.buildRustPackage {
-  pname = "yts";
-  version = "0.1.0";
-
-  src = ./.;
-  cargoLock = {
-    lockFile = ./Cargo.lock;
-  };
-
-  buildNoDefaultFeatures = true;
-  buildFeatures = ["yts"];
-
-  nativeBuildInputs = [
-    makeWrapper
-  ];
-
-  postInstall = ''
-    wrapProgram $out/bin/yts \
-      --prefix PATH : ${lib.makeBinPath [ytcc]}
-  '';
-}