about summary refs log tree commit diff stats
path: root/pkgs/sources/update_vim_plugins/package.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:26:22 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:26:22 +0200
commit204731c0a69136c9cebcb54f1afecf5145e26bbe (patch)
treefc9132e5dc74e4a8e1327cdd411839a90f9410aa /pkgs/sources/update_vim_plugins/package.nix
parentrefactor(sys): Modularize and move to `modules/system` or `pkgs` (diff)
downloadnixos-config-204731c0a69136c9cebcb54f1afecf5145e26bbe.tar.gz
nixos-config-204731c0a69136c9cebcb54f1afecf5145e26bbe.zip
refactor(pkgs): Categorize into `by-name` shards
This might not be the perfect way to organize a package set --
especially if the set is not nearly the size of nixpkgs -- but it is
_at_ least a way of organization.
Diffstat (limited to 'pkgs/sources/update_vim_plugins/package.nix')
-rw-r--r--pkgs/sources/update_vim_plugins/package.nix47
1 files changed, 0 insertions, 47 deletions
diff --git a/pkgs/sources/update_vim_plugins/package.nix b/pkgs/sources/update_vim_plugins/package.nix
deleted file mode 100644
index e74a29b1..00000000
--- a/pkgs/sources/update_vim_plugins/package.nix
+++ /dev/null
@@ -1,47 +0,0 @@
-{
-  python3,
-  # dependencies
-  nix,
-  alejandra,
-  nix-prefetch-git,
-}:
-python3.pkgs.buildPythonApplication {
-  pname = "update-vim-plugins";
-  version = "0.1.0";
-  format = "pyproject";
-
-  src = ./.;
-
-  # NOTE: The test are not really meant to work <2023-12-09>
-  doCheck = false;
-
-  nativeBuildInputs = [
-    python3.pkgs.poetry-core
-  ];
-  buildInputs = [
-    alejandra
-    nix-prefetch-git
-    nix
-  ];
-  propagatedBuildInputs = with python3.pkgs; [
-    requests
-    cleo
-    jsonpickle
-    dateparser
-  ];
-  nativeCheckInputs = with python3.pkgs; [
-    pytestCheckHook
-
-    pytest-cov
-    pytest-mock
-  ];
-  pytestFlagsArray = [
-    "--cov"
-    "update_vim_plugins"
-    "--cov-report"
-    "term-missing:skip-covered"
-    "--cov-fail-under"
-    "50"
-    "update_vim_plugins/tests"
-  ];
-}