about summary refs log tree commit diff stats
path: root/pkgs/sources/update_pkgs.sh
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-20 16:10:21 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-20 16:14:26 +0200
commit368cb6b0d25db2ae23be42ad51584de059997e51 (patch)
tree3282e45d3ebced63c8498a47e83a255c35de620b /pkgs/sources/update_pkgs.sh
parentrefactor(hm): Rename to `modules/home` (diff)
downloadnixos-config-368cb6b0d25db2ae23be42ad51584de059997e51.tar.gz
nixos-config-368cb6b0d25db2ae23be42ad51584de059997e51.zip
refactor(sys): Modularize and move to `modules/system` or `pkgs`
Diffstat (limited to 'pkgs/sources/update_pkgs.sh')
-rwxr-xr-xpkgs/sources/update_pkgs.sh25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkgs/sources/update_pkgs.sh b/pkgs/sources/update_pkgs.sh
new file mode 100755
index 00000000..be1573c6
--- /dev/null
+++ b/pkgs/sources/update_pkgs.sh
@@ -0,0 +1,25 @@
+#!/usr/bin/env sh
+
+die() {
+    printf "\033[31;1mError: \033[0m%s" "$1"
+    exit 1
+}
+
+cd "$(dirname "$0")" || die "Bug: run with false dirname ('$0')!"
+
+fd . --type directory --max-depth 1 | while read -r dir; do
+    cd "$dir" || die "Dir '$dir' does not exist"
+
+    if [ -f update.sh ]; then
+        printf "\033[34;1m> \033[0m\033[34;1m%s\033[0m\n" "Running '${dir}update.sh'"
+
+        [ -f flake.nix ] && nix flake update
+
+        direnv allow
+        eval "$(direnv export bash 2>/dev/null)"
+        ./update.sh "$@"
+    fi
+    cd - >/dev/null || die "Bug: Last dir does not exist"
+done
+
+# vim: ft=sh