about summary refs log tree commit diff stats
path: root/pkgs/sources/comments/comments.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:26:22 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:26:22 +0200
commit204731c0a69136c9cebcb54f1afecf5145e26bbe (patch)
treefc9132e5dc74e4a8e1327cdd411839a90f9410aa /pkgs/sources/comments/comments.nix
parentrefactor(sys): Modularize and move to `modules/system` or `pkgs` (diff)
downloadnixos-config-204731c0a69136c9cebcb54f1afecf5145e26bbe.tar.gz
nixos-config-204731c0a69136c9cebcb54f1afecf5145e26bbe.zip
refactor(pkgs): Categorize into `by-name` shards
This might not be the perfect way to organize a package set --
especially if the set is not nearly the size of nixpkgs -- but it is
_at_ least a way of organization.
Diffstat (limited to 'pkgs/sources/comments/comments.nix')
-rw-r--r--pkgs/sources/comments/comments.nix25
1 files changed, 0 insertions, 25 deletions
diff --git a/pkgs/sources/comments/comments.nix b/pkgs/sources/comments/comments.nix
deleted file mode 100644
index e8a33bff..00000000
--- a/pkgs/sources/comments/comments.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-{
-  lib,
-  rustPlatform,
-  makeWrapper,
-  less,
-  coreutils,
-}:
-rustPlatform.buildRustPackage {
-  pname = "comments";
-  version = "0.1.0";
-
-  src = ./.;
-  cargoLock = {
-    lockFile = ./Cargo.lock;
-  };
-
-  nativeBuildInputs = [
-    makeWrapper
-  ];
-
-  postInstall = ''
-    wrapProgram $out/bin/comments \
-      --set PATH ${lib.makeBinPath [less coreutils]}
-  '';
-}