about summary refs log tree commit diff stats
path: root/modules/system/sound/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
commitc52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c (patch)
treee8b947710b467b32740598ff574982097836f66c /modules/system/sound/default.nix
parentchore(pkgs/yt): 1.2.1 -> 1.3.0 (diff)
downloadnixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.tar.gz
nixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.zip
refactor(modules): Move all system modules to `by-name`
From now on all modules should be added to the new `by-name` directory.
This should help remove the (superficial and utterly useless)
distinction between `home-manager` and `NixOS` modules.
Diffstat (limited to 'modules/system/sound/default.nix')
-rw-r--r--modules/system/sound/default.nix37
1 files changed, 0 insertions, 37 deletions
diff --git a/modules/system/sound/default.nix b/modules/system/sound/default.nix
deleted file mode 100644
index f3120a67..00000000
--- a/modules/system/sound/default.nix
+++ /dev/null
@@ -1,37 +0,0 @@
-{
-  config,
-  lib,
-  ...
-}: let
-  cfg = config.soispha.sound;
-in {
-  options.soispha.sound = {
-    enable = lib.mkEnableOption "sound based on pipewire";
-  };
-
-  config = lib.mkIf cfg.enable {
-    hardware.pulseaudio.enable = false;
-    security.rtkit.enable = true;
-
-    services.pipewire = {
-      enable = true;
-      alsa.enable = true;
-      alsa.support32Bit = true;
-      pulse.enable = true;
-      jack.enable = true;
-    };
-
-    # TODO: Find a better way to set the default volume <2024-03-10>
-    #
-    # environment.etc.pipewire-pulse-config = {
-    #   target = "pipewire/pipewire-pulse.conf.d/pipewire-pulse-config.conf";
-    #   text = ''
-    #     # Extra scripts can be started here. Setup in default.pa can be moved in
-    #     # a script or in pulse.cmd below
-    #     context.exec = [
-    #         { path = "${pkgs.pulseaudio}/bin/pactl"        args = "set-sink-volume 0 13%" }
-    #     ]
-    #   '';
-    # };
-  };
-}