about summary refs log tree commit diff stats
path: root/modules/system/impermanence/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
commitc52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c (patch)
treee8b947710b467b32740598ff574982097836f66c /modules/system/impermanence/default.nix
parentchore(pkgs/yt): 1.2.1 -> 1.3.0 (diff)
downloadnixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.tar.gz
nixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.zip
refactor(modules): Move all system modules to `by-name`
From now on all modules should be added to the new `by-name` directory.
This should help remove the (superficial and utterly useless)
distinction between `home-manager` and `NixOS` modules.
Diffstat (limited to 'modules/system/impermanence/default.nix')
-rw-r--r--modules/system/impermanence/default.nix57
1 files changed, 0 insertions, 57 deletions
diff --git a/modules/system/impermanence/default.nix b/modules/system/impermanence/default.nix
deleted file mode 100644
index 9730dde6..00000000
--- a/modules/system/impermanence/default.nix
+++ /dev/null
@@ -1,57 +0,0 @@
-{
-  config,
-  lib,
-  ...
-}: let
-  cfg = config.soispha.impermanence;
-in {
-  options.soispha.impermanence = {
-    enable = lib.mkEnableOption "persisting directories and files with impermanence";
-
-    directories = lib.mkOption {
-      type = lib.types.listOf lib.types.str;
-      default =
-        [
-          "/etc/nixos"
-          "/var/log"
-          "/var/lib/systemd"
-          "/var/lib/nixos"
-        ]
-        ++ lib.optional config.networking.networkmanager.enable "/etc/NetworkManager"
-        ++ lib.optional config.boot.lanzaboote.enable "/etc/secureboot"
-        ++ lib.optional config.hardware.bluetooth.enable "/var/lib/bluetooth"
-        ++ lib.optional config.virtualisation.waydroid.enable "/var/lib/waydroid"
-        ++ lib.optional config.services.postgresql.enable "/var/lib/postgresql";
-
-      defaultText = lib.literalExpression ''
-        [
-          "/etc/nixos"
-          "/var/log"
-          "/var/lib/systemd"
-          "/var/lib/nixos"
-        ]
-        ++ lib.optional config.networking.networkmanager.enable "/etc/NetworkManager"
-        ++ lib.optional config.boot.lanzaboote.enable "/etc/secureboot"
-        ++ lib.optional config.hardware.bluetooth.enable "/var/lib/bluetooth"
-        ++ lib.optional config.virtualisation.waydroid.enable "/var/lib/waydroid"
-        ++ lib.optional config.services.postgresql.enable "/var/lib/postgresql"
-      '';
-      description = "The directories to persist";
-    };
-  };
-
-  config = lib.mkIf cfg.enable {
-    # needed for the hm impermanence config
-    programs.fuse.userAllowOther = true;
-
-    environment.persistence = {
-      "/srv" = {
-        hideMounts = true;
-        inherit (cfg) directories;
-        files = [
-          "/etc/machine-id"
-        ];
-      };
-    };
-  };
-}