about summary refs log tree commit diff stats
path: root/modules/home/conf/taskwarrior/firefox/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
commitc52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c (patch)
treee8b947710b467b32740598ff574982097836f66c /modules/home/conf/taskwarrior/firefox/default.nix
parentchore(pkgs/yt): 1.2.1 -> 1.3.0 (diff)
downloadnixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.tar.gz
nixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.zip
refactor(modules): Move all system modules to `by-name`
From now on all modules should be added to the new `by-name` directory.
This should help remove the (superficial and utterly useless)
distinction between `home-manager` and `NixOS` modules.
Diffstat (limited to 'modules/home/conf/taskwarrior/firefox/default.nix')
-rw-r--r--modules/home/conf/taskwarrior/firefox/default.nix32
1 files changed, 0 insertions, 32 deletions
diff --git a/modules/home/conf/taskwarrior/firefox/default.nix b/modules/home/conf/taskwarrior/firefox/default.nix
deleted file mode 100644
index fb5daaa8..00000000
--- a/modules/home/conf/taskwarrior/firefox/default.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-{
-  config,
-  lib,
-  # options
-  prefConfig,
-  profile_size,
-  search,
-  userChrome,
-  ...
-}: let
-  inherit (config.soispha.taskwarrior.projects) projects;
-
-  mkFirefoxProfile = {
-    name,
-    id,
-  }: {
-    inherit name;
-    value = {
-      isDefault = false;
-      extraConfig = prefConfig;
-      inherit id name search userChrome;
-    };
-  };
-  projects_id =
-    lib.imap0 (id: project: {
-      name = project;
-      id = id + profile_size;
-    })
-    projects;
-  firefoxProfiles = builtins.listToAttrs (builtins.map mkFirefoxProfile projects_id);
-in
-  firefoxProfiles