about summary refs log tree commit diff stats
path: root/modules/home/conf/swayidle/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:31:11 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:33:40 +0200
commitfd9b0ecef4142a62b45404700ba1cff488f84a73 (patch)
treeef6c1f74f05a2220a41ccff4b0890c39229f32f7 /modules/home/conf/swayidle/default.nix
parentrefactor(pkgs): Categorize into `by-name` shards (diff)
downloadnixos-config-fd9b0ecef4142a62b45404700ba1cff488f84a73.tar.gz
nixos-config-fd9b0ecef4142a62b45404700ba1cff488f84a73.zip
refactor(modules/home): Setup as "normal" NixOS module
Diffstat (limited to 'modules/home/conf/swayidle/default.nix')
-rw-r--r--modules/home/conf/swayidle/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/modules/home/conf/swayidle/default.nix b/modules/home/conf/swayidle/default.nix
new file mode 100644
index 00000000..6b8a7d80
--- /dev/null
+++ b/modules/home/conf/swayidle/default.nix
@@ -0,0 +1,29 @@
+{
+  config,
+  pkgs,
+  ...
+}: {
+  xdg.configFile."swayidle/config".source = ./config;
+
+  #  services.swayidle = {
+  #    enable = true;
+  #    events = [
+  #      {
+  #        event = "before-sleep";
+  #        command = "${pkgs.swaylock}/bin/swaylock -f ";
+  #      }
+  #    ];
+  #    timeouts = [
+  #      {
+  #        timeout = 180;
+  #        command = "${pkgs.swaylock}/bin/swaylock -fFu ";
+  #      }
+  #      {
+  #        timeout = 360;
+  #        # TODO: systemctl is installed?
+  #        command = "systemctl suspend-then-hibernate";
+  #      }
+  #    ];
+  #    # systemdTarget = ""; # TODO: this might be usefull
+  #  };
+}