about summary refs log tree commit diff stats
path: root/modules/home/conf/nvim/plgs/vim-tex/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:31:11 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:33:40 +0200
commitfd9b0ecef4142a62b45404700ba1cff488f84a73 (patch)
treeef6c1f74f05a2220a41ccff4b0890c39229f32f7 /modules/home/conf/nvim/plgs/vim-tex/default.nix
parentrefactor(pkgs): Categorize into `by-name` shards (diff)
downloadnixos-config-fd9b0ecef4142a62b45404700ba1cff488f84a73.tar.gz
nixos-config-fd9b0ecef4142a62b45404700ba1cff488f84a73.zip
refactor(modules/home): Setup as "normal" NixOS module
Diffstat (limited to 'modules/home/conf/nvim/plgs/vim-tex/default.nix')
-rw-r--r--modules/home/conf/nvim/plgs/vim-tex/default.nix57
1 files changed, 57 insertions, 0 deletions
diff --git a/modules/home/conf/nvim/plgs/vim-tex/default.nix b/modules/home/conf/nvim/plgs/vim-tex/default.nix
new file mode 100644
index 00000000..70ec7f5b
--- /dev/null
+++ b/modules/home/conf/nvim/plgs/vim-tex/default.nix
@@ -0,0 +1,57 @@
+{...}: {
+  programs.nixvim = {
+    opts.conceallevel = 0;
+
+    plugins.vimtex = {
+      enable = true;
+      settings = {
+        view_method = "zathura";
+        quickfix_mode = -1;
+        view_enabled = -1;
+        tex_conceal = "abdmg";
+        tex_flavor = "latex";
+
+        # Useful if treesitter is the highlighter
+        syntax_enabled = 0;
+        syntax_conceal_disable = 1;
+
+        mappings_disable = {
+          n = ["tsf" "tsc" "tse" "ts$" "tsd" "tsD"];
+          x = ["tsd" "tsD" "tsf"];
+        };
+
+        toc_config = {
+          name = "TOC";
+          layers = ["content" "todo" "include"];
+          resize = false;
+          split_width = 49;
+          todo_sorted = -1;
+          show_help = false;
+          show_numbers = false;
+          mode = true;
+          layer_keys = {
+            content = "C";
+            label = "L";
+            todo = "j";
+            include = "I";
+          };
+        };
+
+        compiler_latexmk = {
+          build_dir = "build";
+          callback = false;
+          continuous = true;
+          executable = "latexmk";
+          hooks = [];
+          options = [
+            "-verbose"
+            "-file-line-error"
+            "-synctex=0"
+            "-interaction=nonstopmode"
+            "-outdir=build"
+          ];
+        };
+      };
+    };
+  };
+}